[jifty-devel] debugging jifty, EMAGIC

Gaal Yahas gaal at forum2.org
Mon Oct 16 06:33:36 EDT 2006


    perl -Ilib bin/jifty server

When invoked like this, the HTTP server goes into some whacky mode where
it listens on stdin for requests, or for parts of them(?). In any case,
neither this nor -d:Trace accepts web connections from a browser that
worked without them.

This is a shame, because I'm having some weird problems in an action I'm
writing. At first, the action seemed to be silently ignored:

    DEBUG - Taking action TheApp::Action::InstallSomething auto-S66740
    DEBUG - Result: 1

(Debug prints and "die"s in take_action weren't called.)

Then after fiddling with the action class a little but (I commented out
a validation routine which wasn't being called either), I'm suddely
getting these errors:

    Undefined subroutine &MyApp::Action::InstallSomething::take_action
    called at /root/src/jifty/lib/Jifty/Action.pm line 212.

Now, I was thinking maybe there was some lexical error or something in
my action class, and it wasn't being loaded so a default null action
was installed instead. (Does the class loader stay silent when that
happens?) But because I can't debug, earlier I also had tried inserting
a call just before Jifty::Action:212, to a method in my action class
that just emits a debug print. That call was successful. What gives?

Gaal Yahas <gaal at forum2.org>

More information about the jifty-devel mailing list