[jifty-devel] Rrror: Can't locate object method "port" via package "Jifty::Server"

Sean E. Millichamp sean at enertronllc.com
Thu Jan 19 17:23:01 EST 2006

I have been trying to get through the Jifty tutorial but so far haven't
had success.

Currently, I am trying to start the Jifty standalone server:

[MyWebLog]$ ./bin/jifty server
Can't locate object method "port" via package "Jifty::Server" at
bin/../../Jifty/lib/Jifty/Server.pm line 111, <DATA> line 16.

After doing some digging in the code it seems that the 'port' method
ought to be inherited from the HTTP::Server::Simple class (via
HTTP::Server::Simple::Mason).  Presumably perl is finding and loading
all of the dependencies or I would get an error about it not being able
to load whatever was missing.

I wrote a very simple little test program to see if it could find the
port method if I use'd HTTP::Server::Simple directly and it seemed to

As far as I can tell, I have satisfied all of Jifty's dependencies -
running 'perl Makefile.PL' shows that all modules are accounted for.

I have HTTP::Server::Simple 0.16 and HTTP::Server::Simple::Mason 0.09.

Currently this is using the Jifty-0.51225 download from jifty.org but I
have also tried this with Jifty SVN and gotten the same error.

Any ideas?  In case it matters, this is a Fedora Core 4 box w/updates
applied.  Some of the module dependencies are being supplied by RPMs
but, as I said, it seems to pass Jifty's requirements.


PS: Jifty looks very cool - I'm looking forward to playing with it.

 Sean E. Millichamp, Enertron LLC, 586-757-1200 x102
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.bestpractical.com/pipermail/jifty-devel/attachments/20060119/6521190d/attachment.pgp

More information about the jifty-devel mailing list